Author Archives: sillyscientist

Home Automation: Integrating Salus RT500 RF in OpenHAB using a Jeelink

We recently had a new boiler fitted with the Salus RT500RF controller. I’ve been playing around with a lot of home automation recently involving LightwaveRF, RFXCom unit and OpenHAB. Having temperature monitoring in my lounge and bedroom I really wanted … Continue reading

Posted in Home Automation | Tagged , , , , , , , , , , , , | 21 Comments

Accessing partitions within an image or LVM volume used as an iSCSI target

I recently reinstalled the software on my NAS (open media vault) and tidied up the host name etc. As part of this I changed the name of the iSCSI target. This meant that my media PC wouldn’t boot over the … Continue reading

Posted in Home Network, Howto, Server Admin | Tagged , , , , , , | Leave a comment

/dev/md0 can’t read superblock

Sometimes when my Stora NAS gets rebooted the array fails to mount and I get /dev/md0 can’t read superblock To correct this I do the following: Try mount /dev/md0 (you probably tried this and got the above error) Do xfs_repair … Continue reading

Posted in Home Network, Howto | Tagged , , , , | Leave a comment

XBMC Frodo for Legacy AMD Graphics Cards (pre 5xxx)

Apparently AMD/ATI graphics cards less than 5xxx series have been left behind in the latest drivers. This is a bit of a pain for me as I have a 24xx series in my media PC. I tried the stock XBMCbuntu … Continue reading

Posted in Home Network, Howto, Projects | Tagged , , , , , , , , , | 1 Comment

MediaPC in a Xen Virtual Machine

The aim of this project was to get my MediaPC running as a VM host. This would allow me to run instances alongside my MediaPC, thus giving me a platform to experiment and develop things without having to setup separate machines etc. … Continue reading

Posted in Howto, Projects, Virtualised Media PC | Tagged , , , , , | 1 Comment

Indefero errors fatal: bad argument fatal: The remote end hung up unexpectedly

I was trying to commit something to my Indefero project management server today and was getting the following error: fatal: bad argument fatal: The remote end hung up unexpectedly I puzzled around for a while and then tried manually logging … Continue reading

Posted in Howto, Server Admin | Tagged , , , , | Leave a comment

Getting JetPack working

I had two issues with JetPack – but I finally got it working. Issue one –  Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. Operation timed out after 15000 milliseconds with … Continue reading

Posted in Howto, Server Admin | Tagged , , , , , , | 1 Comment

Lenovo USB Modem in Linux (Ubuntu 10.04)

I recently bought a Lenovo USB modem for some experiments in telephony that I am working on. I want it to work on Linux. It is based on the Conexant RD02-D400 device. When plugging it in I get the following … Continue reading

Posted in Howto, Projects, Telephony | Tagged , , , , , , , , , | 7 Comments

Pairing Apple 1st Gen Keyboard (A1016) with Windows 7

I was having some errors pairing the Apple 1st Gen bluetooth keyboard to my media centre. I discovered that you need todo the following: Turn on the keyboard Open up Bluetooth ‘Add Devices’ and wait for windows to discover the … Continue reading

Posted in Howto | Tagged , , , , , , | 3 Comments

Stupid things you should not do #1

> python generator.py –help Opening –help Outputting start code… Outputting template… Writing out finish… Done Do’h!! > ls –help generator.py > rm –help rm: illegal option — – usage: rm [-f | -i] [-dPRrvW] file … unlink file > rm … Continue reading

Posted in Stupid things you should not do | Tagged | 2 Comments